<!DOCTYPE html>
<html lang="fr-FR" class="no-js">
    <head>
        <meta name="viewport" content="width=device-width, initial-scale=1">
        <link rel="profile" href="http://gmpg.org/xfn/11">
	    <meta charset="UTF-8" />
<title>[Raspberry Pi] Mettre tout le système sur disque dur USB ou SSD (et ne plus utiliser de carte SD) - Nicolas FORCET</title>
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="generator" content="Page Speed 1.58" />

<!-- This site is optimized with the Yoast SEO plugin v12.8 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/" />
<meta property="og:locale" content="fr_FR" />
<meta property="og:type" content="article" />
<meta property="og:title" content="[Raspberry Pi] Mettre tout le système sur disque dur USB ou SSD (et ne plus utiliser de carte SD) - Nicolas FORCET" />
<meta property="og:description" content="Ce qui devait arriver arriva&#8230; Ma carte SD accueillant le système Raspbian de mon Raspberry Pi est morte au bout d&rsquo;un an d&rsquo;uptime, malgré : l&rsquo;utilisation de l&rsquo;excellent log2ram (voir le tutoriel chez arduino103), permettant le mise en mémoire RAM des fichiers logs de Linux Raspbian pour limiter les accès en écriture à la carte
Lire la suite &rarr;" />
<meta property="og:url" content="https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/" />
<meta property="og:site_name" content="Nicolas FORCET" />
<meta property="article:tag" content="Raspberry Pi" />
<meta property="article:tag" content="Raspbian" />
<meta property="article:tag" content="SSD" />
<meta property="article:section" content="Linux et Raspberry Pi" />
<meta property="article:published_time" content="2019-07-10T12:26:17+00:00" />
<meta property="article:modified_time" content="2019-10-27T08:36:03+00:00" />
<meta property="og:updated_time" content="2019-10-27T08:36:03+00:00" />
<meta property="og:image" content="https://nicolasforcet.com/wp-content/uploads/2019/07/Raspberry-PI-Raspbian-sur-SSD-HDD-USB.png" />
<meta property="og:image:secure_url" content="https://nicolasforcet.com/wp-content/uploads/2019/07/Raspberry-PI-Raspbian-sur-SSD-HDD-USB.png" />
<meta property="og:image:width" content="600" />
<meta property="og:image:height" content="497" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Ce qui devait arriver arriva&#8230; Ma carte SD accueillant le système Raspbian de mon Raspberry Pi est morte au bout d&rsquo;un an d&rsquo;uptime, malgré : l&rsquo;utilisation de l&rsquo;excellent log2ram (voir le tutoriel chez arduino103), permettant le mise en mémoire RAM des fichiers logs de Linux Raspbian pour limiter les accès en écriture à la carte Lire la suite &rarr;" />
<meta name="twitter:title" content="[Raspberry Pi] Mettre tout le système sur disque dur USB ou SSD (et ne plus utiliser de carte SD) - Nicolas FORCET" />
<meta name="twitter:image" content="https://nicolasforcet.com/wp-content/uploads/2019/07/Raspberry-PI-Raspbian-sur-SSD-HDD-USB.png" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://nicolasforcet.com/#website","url":"https://nicolasforcet.com/","name":"Nicolas FORCET","description":"Blog personnel high-tech, litt\u00e9rature et sport.","publisher":{"@id":"https://nicolasforcet.com/#/schema/person/"},"potentialAction":{"@type":"SearchAction","target":"https://nicolasforcet.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#primaryimage","url":"https://nicolasforcet.com/wp-content/uploads/2019/07/Raspberry-PI-Raspbian-sur-SSD-HDD-USB.png","width":600,"height":497,"caption":"Raspberry PI Raspbian sur SSD HDD USB"},{"@type":"WebPage","@id":"https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#webpage","url":"https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/","inLanguage":"fr-FR","name":"[Raspberry Pi] Mettre tout le syst\u00e8me sur disque dur USB ou SSD (et ne plus utiliser de carte SD) - Nicolas FORCET","isPartOf":{"@id":"https://nicolasforcet.com/#website"},"primaryImageOfPage":{"@id":"https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#primaryimage"},"datePublished":"2019-07-10T12:26:17+00:00","dateModified":"2019-10-27T08:36:03+00:00"},{"@type":"Article","@id":"https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#article","isPartOf":{"@id":"https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#webpage"},"author":{"@id":"https://nicolasforcet.com/#/schema/person/9cebc48fb38353624e2e57bae6297a66"},"headline":"[Raspberry Pi] Mettre tout le syst\u00e8me sur disque dur USB ou SSD (et ne plus utiliser de carte SD)","datePublished":"2019-07-10T12:26:17+00:00","dateModified":"2019-10-27T08:36:03+00:00","commentCount":"6","mainEntityOfPage":{"@id":"https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#webpage"},"publisher":{"@id":"https://nicolasforcet.com/#/schema/person/"},"image":{"@id":"https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#primaryimage"},"keywords":"Raspberry Pi,Raspbian,SSD","articleSection":"Linux et Raspberry Pi"},{"@type":["Person"],"@id":"https://nicolasforcet.com/#/schema/person/9cebc48fb38353624e2e57bae6297a66","name":"Nicolas","image":{"@type":"ImageObject","@id":"https://nicolasforcet.com/#authorlogo","url":"https://secure.gravatar.com/avatar/517a83e8793b5b9f5b6dadca39fcffb5?s=96&d=mm&r=x","caption":"Nicolas"},"description":"Bordelais passionn\u00e9 de nouvelles technologies, pratiquant de Kitesurf et fervent d\u00e9gustateur de soupe de poisson.","sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Nicolas FORCET &raquo; Flux" href="https://nicolasforcet.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Nicolas FORCET &raquo; Flux des commentaires" href="https://nicolasforcet.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/nicolasforcet.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<link rel='stylesheet' id='pagespeed-icons-css'  href='https://nicolasforcet.com/wp-content/themes/page-speed/assets/css/font-icons.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='pagespeed-generated-css'  href='https://nicolasforcet.com/wp-content/uploads/page-speed-nico.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='pagespeed-print-styles-css'  href='https://nicolasforcet.com/wp-content/themes/page-speed/assets/css/print-styles.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://nicolasforcet.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://nicolasforcet.com/wp-content/themes/page-speed/style.css?ver=5.3.2' type='text/css' media='all' />
<script type='text/javascript' src='https://nicolasforcet.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://nicolasforcet.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://nicolasforcet.com/wp-content/themes/page-speed/assets/js/vendors.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://nicolasforcet.com/wp-content/themes/page-speed/assets/js/custom.min.js?ver=5.3.2'></script>
<link rel='https://api.w.org/' href='https://nicolasforcet.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nicolasforcet.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nicolasforcet.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://nicolasforcet.com/?p=10676' />
<link rel="alternate" type="application/json+oembed" href="https://nicolasforcet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnicolasforcet.com%2F2019%2F07%2F10%2Fraspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nicolasforcet.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnicolasforcet.com%2F2019%2F07%2F10%2Fraspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd%2F&#038;format=xml" />

		    </head>
<body class="wordpress ltr fr fr-fr child-theme y2020 m01 d23 h22 thursday logged-out singular singular-post singular-post-10676 desktop has-thumb layout-r-sb container-regular single-regular sleek-header">

<div id="wrapper" class="cf">

    <div id="site-header-container"
         class="cf logo-left">
        <div class="hybrid cf">
            <div class="inner">
				        <header id="site-header" role="banner" class="cf">
            <div id="site-branding" >
									                    <h3 class="site-title"><a href="https://nicolasforcet.com/"
                                              rel="home">Nicolas FORCET</a></h3>
				                        <p class="site-description">Blog personnel high-tech, littérature et sport.</p>
									            </div><!-- .site-branding -->

        </header><!-- #site-header -->
		    <div id="menu" class="open-drawer">
        <svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg"
             xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
             width="32px" height="32px" viewBox="0 0 437.311 435.856"
             enable-background="new 0 0 437.311 435.856"
             xml:space="preserve">
				<path d="M425.472,107.49c0,0-14.061-67.125-74.835-90.709C322.064,5.443,269.906,0.454,218.656,0
					c-51.25,0.454-103.408,5.443-131.981,16.328C25.899,39.912,11.84,107.037,11.84,107.037C2.769,145.134-0.406,183.686,0.047,217.701
					c-0.454,34.016,2.268,73.021,11.792,110.665c0,0,14.06,67.124,74.834,90.709c28.573,10.885,80.731,16.327,131.981,16.781
					c51.25-0.454,103.408-5.443,131.981-16.781c60.774-23.585,74.835-90.709,74.835-90.709c9.07-38.098,12.245-76.649,11.792-110.665
					C437.717,184.139,434.997,145.134,425.472,107.49z M311.179,309.317H126.133V281.65h185.5v27.667H311.179z M311.179,230.4H126.133
					v-27.666h185.5V230.4H311.179z M311.179,154.659H126.133v-27.666h185.5v27.666H311.179z"/>
				</svg>
    </div>
					        <div id="header-nav-container" class="cf has-sticky-logo">
            <div id="primary" class="">
								<nav id="header-nav" class="nav"><ul id="menu-liens" class="menu cf"><li id="menu-item-10287" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-10287"><a href="https://nicolasforcet.com">Accueil</a></li>
<li id="menu-item-10290" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10290"><a href="https://nicolasforcet.com/tests-de-materiel-high-tech/">Tests de matériel High Tech</a></li>
<li id="menu-item-10288" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10288"><a href="https://nicolasforcet.com/randonnees/">Randonnées</a></li>
<li id="menu-item-10289" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10289"><a href="https://nicolasforcet.com/a-propos/">A Propos</a></li>
<li id="menu-item-10291" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-10291"><a href="https://nicolasforcet.com/mentions-legales/">Contact / Protection des données</a></li>
</ul></nav>				            </div>
        </div>
		            </div>
        </div>
    </div><!--#site-header-container -->
    <div id="content-wrapper">
    <div id="content" class="cf hybrid">
    <div id="left">
        <main id="main" role="main">
            <div class="inner">
	
	
<article id="post-10676" class="entry author-nforcet post-10676 post type-post status-publish format-standard has-post-thumbnail category-linux-raspberry-pi tag-raspberry-pi tag-raspbian tag-ssd">
    <header class="entry-header">
				<h1 class="entry-title">[Raspberry Pi] Mettre tout le système sur disque dur USB ou SSD (et ne plus utiliser de carte SD)</h1>		            <div class="entry-meta meta below-title">
				<span>Le&nbsp;</span><span></span><span class="date updated"><a class="" href="https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/" title="13:26" rel="bookmark"><time class="entry-date" datetime="2019-07-10T13:26:17+01:00">10 juillet 2019</time></a></span> &nbsp;<span>- &nbsp;</span><div class="tags"><a href="https://nicolasforcet.com/tag/raspberry-pi/" rel="tag">Raspberry Pi</a> <a href="https://nicolasforcet.com/tag/raspbian/" rel="tag">Raspbian</a> <a href="https://nicolasforcet.com/tag/ssd/" rel="tag">SSD</a></div>&nbsp;dans&nbsp;<a href="https://nicolasforcet.com/category/linux-raspberry-pi/" rel="category tag">Linux et Raspberry Pi</a>&nbsp;<hr class="separator">            </div>
		    </header>
    <!-- .entry-header -->


    <div class="entry-content">
		<p><img class="alignnone size-full wp-image-10684" src="https://nicolasforcet.com/wp-content/uploads/2019/07/Raspberry-PI-Raspbian-sur-SSD-HDD-USB.png" alt="Raspberry PI Raspbian sur SSD HDD USB" width="600" height="497" srcset="https://nicolasforcet.com/wp-content/uploads/2019/07/Raspberry-PI-Raspbian-sur-SSD-HDD-USB.png 600w, https://nicolasforcet.com/wp-content/uploads/2019/07/Raspberry-PI-Raspbian-sur-SSD-HDD-USB-300x249.png 300w" sizes="(max-width: 600px) 100vw, 600px" /></p>
<p>Ce qui devait arriver arriva&#8230; Ma carte SD accueillant le système Raspbian de mon Raspberry Pi est morte au bout d&rsquo;un an d&rsquo;uptime, malgré :</p>
<ul>
<li>l&rsquo;utilisation de l&rsquo;excellent <em><strong>log2ram</strong></em> (voir le <a href="https://arduino103.blogspot.com/2018/08/log2ram-ecrire-les-logs-dans-la-ram.html">tutoriel chez arduino103</a>), permettant le mise en mémoire RAM des fichiers logs de Linux Raspbian pour limiter les accès en écriture à la carte SD</li>
<li>la suppression de la partition swap (pas vu de différence à l&rsquo;utilisation) : voir <a href="https://nicolasforcet.com/2017/04/25/raspberry-pi-ne-pas-utiliser-le-swap-pour-epargner-notre-carte-sd/">tutoriel suppression du swap sur raspberry pi</a></li>
</ul>
<p>Ayant un SSD 256Go qui « trainait » chez moi, j&rsquo;ai branché un cable USB3/SATA dessus et zou, voila une « méga clé USB » adossée au Raspberry Pi. Le but de ce tutoriel est de démarrer le raspberry Pi sur ce SSD/Clé USB/Disque dur et de s&rsquo;affranchir totalement de la carte SD, point de fragilité du système.</p>
<p><a href="https://nicolasforcet.com/wp-content/uploads/2019/07/Raspberry-PI-Raspbian-sur-SSD-HDD-USB2.png"><img class="alignnone size-full wp-image-10685" src="https://nicolasforcet.com/wp-content/uploads/2019/07/Raspberry-PI-Raspbian-sur-SSD-HDD-USB2.png" alt="Raspberry PI Raspbian sur SSD HDD USB2" width="600" height="378" srcset="https://nicolasforcet.com/wp-content/uploads/2019/07/Raspberry-PI-Raspbian-sur-SSD-HDD-USB2.png 600w, https://nicolasforcet.com/wp-content/uploads/2019/07/Raspberry-PI-Raspbian-sur-SSD-HDD-USB2-300x189.png 300w" sizes="(max-width: 600px) 100vw, 600px" /></a></p>
<h1>Permettre le boot depuis les ports USB, sans carte SD insérée</h1>
<p>Cette étape n&rsquo;est possible que sur le Raspberry Pi 3B/3B+, et simplifie grandement la façon de faire. On va écrire dans la mémoire OTP du Raspberry Pi (One-Time Programmable). C&rsquo;est une mémoire non volatile (donc qui ne s’efface pas quand on éteint l&rsquo;appareil) et dont les registres ne peuvent être modifiés <b>qu&rsquo;une seule fois.</b> Rien de bien grave cependant puisque :</p>
<ul>
<li>Nous allons juste dire au Raspberry Pi de booter sur les ports USB s&rsquo;il ne trouve aucun système valide sur le lecteur de carte micro-SD, comme on le ferait dans le bios d&rsquo;un PC</li>
<li>Cela n&#8217;empeche en aucun cas l&rsquo;utilisation classique du Raspberry Pi avec un système sur micro-SD, si vous changez d&rsquo;avis plus tard.</li>
</ul>
<p>Voyons la valeur actuelle inscrite dans la mémoire OTP du Raspberry Pi :</p>
<pre>sudo vcgencmd otp_dump |grep 17</pre>
<p>Vous devriez avoir la valeur <b><span style="color: #ff0000;">17</span>:1020000a</b></p>
<p>On rajoute une petite ligne dans un fichier texte qui va dire au Raspberry de modifier l&rsquo;adresse 17 de la mémoire OTP à la valeur souhaitée, permettant ainsi le boot sur USB :</p>
<pre>echo program_usb_boot_mode=1 | sudo tee -a /boot/config.txt</pre>
<p>On reboote le Raspberry Pi, à la main ou en ligne de commande :</p>
<pre>sudo shutdown -r now</pre>
<p>Une fois redémarré, on lit la valeur de l&rsquo;adresse mémoire 17 dans la mémoire OTP :</p>
<pre>sudo vcgencmd otp_dump |grep 17</pre>
<p>Ca doit nous retourner <b><span style="color: #ff0000;">17</span>:3020000a.</b> Le plus dur est fait ! Le Raspberry Pi peut maintenant booter sur l&rsquo;USB, mais toujours également sur la micro-SD, élargissant ainsi les manips et bidouilles possibles !</p>
<p>Vous pouvez éditer le fichier config pour enlever la ligne « program_usb_boot_mode=1 » devenue inutile, afin de ne pas induire une modification sur un autre Raspberry Pi par erreur si vous y branchez la carte SD.</p>
<pre>sudo nano /boot/config.txt</pre>
<h1>Installer Raspbian sur le SSD</h1>
<p>Téléchargez une version récente de Raspbian (ou autre système de votre choix) et copiez cette image sur le SSD préalablement formaté. S&rsquo;il n&rsquo;est pas formaté, il le sera à cette étape donc vérifiez que vous n&rsquo;avez pas de donnée importante dessus !!!</p>
<p>Télécharger Balena Etcher (<a href="https://www.balena.io/etcher/">ici</a>). C&rsquo;est un logiciel sur Windows et Linux permettant d&rsquo;écrire une image disque sur un support externe. Par défaut, il ne détecte que les supports de petite taille type clé USB ou Cartes SD mais pas les SSD ou HDD.</p>
<p>Il faut donc <span style="color: #ff0000;">aller dans les options et cocher « unsafe mode »</span>.  Il faudra redoubler de prudence en sélectionnant le disque à écrire !! Je vous laisse imaginer le désastre si vous écrivez sur le disque D de votre PC par exemple, avec toutes vos données de travail&#8230;</p>
<p><img class="alignnone size-large wp-image-10680" src="https://nicolasforcet.com/wp-content/uploads/2019/07/Balena-Etcher-copier-image-Raspbian-sur-SSD-620x369.png" alt="Balena-Etcher-copier-image-Raspbian-sur-SSD" width="620" height="369" /></p>
<p>Charger l&rsquo;image disque de Raspbian et sélectionner le BON disque externe. Cliquer sur flash et c&rsquo;est parti !</p>
<p><a href="https://nicolasforcet.com/wp-content/uploads/2019/07/Balena-Etcher-ecriture-sur-SSD-Image-Raspbian-Raspberry-Pi.png"><img class="alignnone size-large wp-image-10681" src="https://nicolasforcet.com/wp-content/uploads/2019/07/Balena-Etcher-ecriture-sur-SSD-Image-Raspbian-Raspberry-Pi-620x373.png" alt="Balena-Etcher-ecriture-sur-SSD-Image-Raspbian-Raspberry-Pi" width="620" height="373" /></a></p>
<p>On peut alors connecter le disque externe ou SSD en USB sur le Raspberry Pi et enlever la carte micro-SD.</p>
<p>Le Raspberry Pi démarrera sur le SSD ou disque dur externe. Le démarrage est plus long de quelques secondes, la séquence de boot cherche si la micro-SD ne lui permet pas de booter avant de passer au hub USB.</p>
<h1>Redimensionner les partitions (facultatif)</h1>
<p>Souhaitant faire des images disques régulières de mon système (ça m&rsquo;a sauvé plus d&rsquo;une fois), il était inconcevable d&rsquo;avoir une partition <em><strong>rootfs</strong></em> de 250Go ! J&rsquo;ai donc éteint le Raspberry, débranché le SSD et l&rsquo;ai branché sur un autre poste afin de redimensionner la partition <em><strong>rootfs</strong></em> (environ 8G suffisent largement) et créer une autre partition d&rsquo;échange en ext4 de 215Go.</p>
<p>L&rsquo;excellent paquet <em><strong>Gparted</strong></em> sous Linux fait bien le travail, après avoir démonté le volume à redimensionner (clic droit &gt; démonter). Aucune clé ne doit apparaitre à droite du nom du volume sinon vous ne pourrez pas le redimensionner.</p>
<p><a href="https://nicolasforcet.com/wp-content/uploads/2019/07/Redimensionner-partitions-Raspberry-Pi-SSD-HDD.png"><img class="alignnone size-large wp-image-10682" src="https://nicolasforcet.com/wp-content/uploads/2019/07/Redimensionner-partitions-Raspberry-Pi-SSD-HDD-620x421.png" alt="gparted-Redimensionner-partitions-Raspberry-Pi-SSD-HDD" width="620" height="421" /></a></p>
<p>Voilà un Raspberry Pi 3B+ en parfait état de marche, fonctionnant sans carte SD et avec un SSD branché en USB, de taille conséquente. A moi les projets farfelus !</p>
        <div class="clear"></div>
		    </div><!-- .entry-content -->

	</article><!-- #post-## -->

	<nav class="navigation post-navigation" role="navigation" aria-label="Publications">
		<h2 class="screen-reader-text">Navigation de l’article</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://nicolasforcet.com/2019/06/23/smart-tv-samsung-changer-de-langue-dans-un-fichier-mkv-et-de-sous-titres/" rel="prev"><span class="screen-reader-text">Previous Post</span><span aria-hidden="true" class="nav-subtitle">&laquo; Previous</span> <span class="nav-title">[Smart TV Samsung] Changer de langue dans un fichier MKV (et de sous titres)</span></a></div><div class="nav-next"><a href="https://nicolasforcet.com/2019/07/14/informatique-verifier-les-secteurs-et-la-sante-dun-disque-dur-et-les-corriger-linux-windows/" rel="next"><span class="screen-reader-text">Next Post</span></span> <span class="nav-title">[Informatique] Vérifier les secteurs et la santé d&rsquo;un disque dur et les corriger (Linux / Windows)</span><span aria-hidden="true" class="nav-subtitle">Next &raquo;</a></div></div>
	</nav>    <div class="clear"></div>
	
<div id="comments" class="comments-area">

	        <h2 class="comments-title">
			6 Replies to &ldquo;[Raspberry Pi] Mettre tout le système sur disque dur USB ou SSD (et ne plus utiliser de carte SD)&rdquo;        </h2>

        <ol class="comment-list">
					<li id="comment-16558" class="comment even thread-even depth-1 parent">
			<article id="div-comment-16558" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://secure.gravatar.com/avatar/c3e6bbc32c03dd3ff0ac8d2e2a451571?s=48&#038;d=mm&#038;r=x' srcset='https://secure.gravatar.com/avatar/c3e6bbc32c03dd3ff0ac8d2e2a451571?s=96&#038;d=mm&#038;r=x 2x' class='avatar avatar-48 photo' height='48' width='48' itemprop="image" />						<b class="fn">Fred</b> <span class="says">dit :</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#comment-16558">
							<time datetime="2019-10-16T16:57:29+01:00">
								16 octobre 2019 à 16:57							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Bonjour j’aimerai savoir si il est possible de faire booter une image recalbox pi 3 b sur<br />
Une pi 3 b+ je ne connaît rien merci</p>
				</div><!-- .comment-content -->

				<div class="reply"><a itemprop="replyToUrl" rel='nofollow' class='comment-reply-link' href='#comment-16558' data-commentid="16558" data-postid="10676" data-belowelement="div-comment-16558" data-respondelement="respond" aria-label='Répondre à Fred'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-16569" class="comment byuser comment-author-nforcet bypostauthor odd alt depth-2 role-administrator role-bbp_keymaster">
			<article id="div-comment-16569" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://secure.gravatar.com/avatar/517a83e8793b5b9f5b6dadca39fcffb5?s=48&#038;d=mm&#038;r=x' srcset='https://secure.gravatar.com/avatar/517a83e8793b5b9f5b6dadca39fcffb5?s=96&#038;d=mm&#038;r=x 2x' class='avatar avatar-48 photo' height='48' width='48' itemprop="image" />						<b class="fn"><a href='http://www.nicolasforcet.com' rel='external nofollow ugc' class='url fn n' itemprop="url"><span itemprop="name">Nicolas</span></a></b> <span class="says">dit :</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#comment-16569">
							<time datetime="2019-10-17T05:38:17+01:00">
								17 octobre 2019 à 05:38							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Bonjour,<br />
Aucun souci, l&rsquo;architecture matérielle est tellement proche que ça passera sans souci !<br />
Bon jeu rétro ;)</p>
				</div><!-- .comment-content -->

							</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-16625" class="comment even thread-odd thread-alt depth-1 parent">
			<article id="div-comment-16625" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://secure.gravatar.com/avatar/?s=48&#038;d=mm&#038;r=x' srcset='https://secure.gravatar.com/avatar/?s=96&#038;d=mm&#038;r=x 2x' class='avatar avatar-48 photo avatar-default' height='48' width='48' itemprop="image" />						<b class="fn">lls</b> <span class="says">dit :</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#comment-16625">
							<time datetime="2019-11-02T02:22:11+01:00">
								2 novembre 2019 à 02:22							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Bonjour,<br />
Je démarre mon RPi 3+ depuis un USB 3.0. Savez-vous si je peux passer sur un RPi 4? Notez que j&rsquo;ai mis à jour le système sur Buster. Mais j&rsquo;hésite à acheter un Pi 4 car je ne suis pas sûr qu&rsquo;il démarrera de la même façon.<br />
Merci :)</p>
				</div><!-- .comment-content -->

				<div class="reply"><a itemprop="replyToUrl" rel='nofollow' class='comment-reply-link' href='#comment-16625' data-commentid="16625" data-postid="10676" data-belowelement="div-comment-16625" data-respondelement="respond" aria-label='Répondre à lls'>Reply</a></div>			</article><!-- .comment-body -->
		<ol class="children">
		<li id="comment-16626" class="comment byuser comment-author-nforcet bypostauthor odd alt depth-2 role-administrator role-bbp_keymaster">
			<article id="div-comment-16626" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://secure.gravatar.com/avatar/517a83e8793b5b9f5b6dadca39fcffb5?s=48&#038;d=mm&#038;r=x' srcset='https://secure.gravatar.com/avatar/517a83e8793b5b9f5b6dadca39fcffb5?s=96&#038;d=mm&#038;r=x 2x' class='avatar avatar-48 photo' height='48' width='48' itemprop="image" />						<b class="fn"><a href='https://www.nicolasforcet.com' rel='external nofollow ugc' class='url fn n' itemprop="url"><span itemprop="name">Nicolas</span></a></b> <span class="says">dit :</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#comment-16626">
							<time datetime="2019-11-02T09:58:07+01:00">
								2 novembre 2019 à 09:58							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Bonjour,<br />
Malheureusement, le Raspberry Pi ne permet pas encore le boot sur USB. Il va falloir être patient, c&rsquo;est prévu très prochainement. Vous pouvez faire une image disque avec Win32 disk imager et la copier sur une carte SD. Elle devrait (j&rsquo;insiste sur devrait) fonctionner sur le RPI4.</p>
				</div><!-- .comment-content -->

							</article><!-- .comment-body -->
		</li><!-- #comment-## -->
</ol><!-- .children -->
</li><!-- #comment-## -->
		<li id="comment-16648" class="comment even thread-even depth-1">
			<article id="div-comment-16648" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://secure.gravatar.com/avatar/ac607dcfc772a6af01688cc824c55340?s=48&#038;d=mm&#038;r=x' srcset='https://secure.gravatar.com/avatar/ac607dcfc772a6af01688cc824c55340?s=96&#038;d=mm&#038;r=x 2x' class='avatar avatar-48 photo' height='48' width='48' itemprop="image" />						<b class="fn">iznobe</b> <span class="says">dit :</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#comment-16648">
							<time datetime="2019-11-08T10:56:02+01:00">
								8 novembre 2019 à 10:56							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>Salut , merci pour ce tuto , facile a mettre en oeuvre .</p>
<p>Cependant , pour repondre a  » lls  » , il est certain que la copie exacte de la carte du pi3 ne permet pas de faire demarrer un pi 4 en l &lsquo; etat.</p>
<p>la partirion du pi4 qui permet le demarrage est bien plus grande que celle du pi 3 , elle est prevu pour le demarrage de tous les pi .<br />
De plus , le pi 4 et le pi3 ont une configuration materielle bien differente ce qui implique des changements dans les pilotes et d&rsquo; autres fichiers du boot .</p>
<p>bref vous l &lsquo; aurez compris , ca ne merchera jamais tel quel .</p>
<p>Cependant , il existe une commande ou procedure ( je ne me rappelle plus ou j &lsquo; ai vu ca , je crois que c  &lsquo; est sur : <a href="https://www.raspberrypi.org/forums/index.php" rel="nofollow ugc">https://www.raspberrypi.org/forums/index.php</a> , mais c &lsquo; est certain que ca existe ) qui permet de modifier la sauvegarde du pi3 et de faire demarrer le pi4 .</p>
<p>evidemment , apres cela revenir en arriere , n &lsquo; est donc pas possible , j &lsquo; entends par là que apres la modification , si vous mettez la carte dans votre pi 3 , il ne demarrera pas .</p>
<p>donc avant de modifier faites une sauvegarde complete de votre SD et placez la en lieu sur !<br />
en cas de probleme ca peut toujours etre utile :P</p>
				</div><!-- .comment-content -->

				<div class="reply"><a itemprop="replyToUrl" rel='nofollow' class='comment-reply-link' href='#comment-16648' data-commentid="16648" data-postid="10676" data-belowelement="div-comment-16648" data-respondelement="respond" aria-label='Répondre à iznobe'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
		<li id="comment-16966" class="comment odd alt thread-odd thread-alt depth-1">
			<article id="div-comment-16966" class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt='' src='https://secure.gravatar.com/avatar/582dca6f9904ada5e6d2bf2254a8e848?s=48&#038;d=mm&#038;r=x' srcset='https://secure.gravatar.com/avatar/582dca6f9904ada5e6d2bf2254a8e848?s=96&#038;d=mm&#038;r=x 2x' class='avatar avatar-48 photo' height='48' width='48' itemprop="image" />						<b class="fn">jms</b> <span class="says">dit :</span>					</div><!-- .comment-author -->

					<div class="comment-metadata">
						<a href="https://nicolasforcet.com/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#comment-16966">
							<time datetime="2019-12-21T09:20:36+01:00">
								21 décembre 2019 à 09:20							</time>
						</a>
											</div><!-- .comment-metadata -->

									</footer><!-- .comment-meta -->

				<div class="comment-content">
					<p>bonjour a tous<br />
J&rsquo;ai un raspberry 3b+ j&rsquo;ai fait la manip pour booter sur un disque dur externe il me retourne  17:3020000a..<br />
j&rsquo;ai un disque externe en ide auto alimenté et sa fonctionne pas y&rsquo;a t&rsquo;il une autre manip a faire?</p>
				</div><!-- .comment-content -->

				<div class="reply"><a itemprop="replyToUrl" rel='nofollow' class='comment-reply-link' href='#comment-16966' data-commentid="16966" data-postid="10676" data-belowelement="div-comment-16966" data-respondelement="respond" aria-label='Répondre à jms'>Reply</a></div>			</article><!-- .comment-body -->
		</li><!-- #comment-## -->
        </ol>

			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Laisser un commentaire <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/07/10/raspberry-pi-mettre-tout-le-systeme-sur-disque-dur-usb-ou-ssd-et-ne-plus-utiliser-de-carte-sd/#respond" style="display:none;">Annuler la réponse</a></small></h3><form action="https://nicolasforcet.com/wp-comments-post.php" method="post" id="commentform" class="comment-form cf" novalidate><p class="comment-notes"><span id="email-notes">Votre adresse de messagerie ne sera pas publiée.</span></p><p class="comment-form-author"><label for="author">Name</label> <input id="author" name="author" type="text" placeholder="Name" value="" size="30" maxlength="245" /></p>
<p class="comment-form-email"><label for="email">Email</label> <input id="email" name="email" placeholder="Email address"type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url"  placeholder="Your website url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Enregistrer mon nom, mon e-mail et mon site web dans le navigateur pour mon prochain commentaire.</label></p>
<p class="comment-form-comment"><label for="comment">Commentaire</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Laisser un commentaire" /> <input type='hidden' name='comment_post_ID' value='10676' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="076d14de79" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="232"/></p></form>	</div><!-- #respond -->
	
</div><!-- #comments -->

</div><!-- main inner-->
</main>
<aside id="sb1" class="cf sb-container">
    <div class="inner cf">

		            <div id="normal-sb" class="sb">
				<section id="search-3" class="widget cf widget_search"><div class="widget-title heading">Je recherche&#8230;</div>
<div class="he-search-wrapper">
	<form role="search" method="get" class="cf widget-search-form" action="https://nicolasforcet.com/">
		<label>
				<span class="screen-reader-text">
		Search for:</span>
		</label>

		<button type="submit" class="search-submit"><span
				class="">Search</span></button>
		<div class="input">
		<input type="search" class="search-field"
		       placeholder="Search&hellip;"
		       value="" name="s"/>
		</div>
	</form>
</div>
<div class="clear"></div></section><section id="categories-8" class="widget cf widget_categories"><div class="widget-title heading">Catégories</div>		<ul>
				<li class="cat-item cat-item-982"><a href="https://nicolasforcet.com/category/google-android/" title="Applications du Google Play Store, astuces Android et Google.">Android et Google</a> (101)
</li>
	<li class="cat-item cat-item-448"><a href="https://nicolasforcet.com/category/iphone-ipod-touch-ipad/" title="L&#039;univers d&#039;Apple, du Mac aux iPods, iPad et autres iPhones.">Apple et iMachins</a> (101)
</li>
	<li class="cat-item cat-item-1062"><a href="https://nicolasforcet.com/category/bd-livres/" title="Mes avis sur les Bandes dessinées, mangas et livres.">BD et Livres</a> (37)
</li>
	<li class="cat-item cat-item-62"><a href="https://nicolasforcet.com/category/blu-ray/" title="Tests de Blu Ray et supports haute définition">Blu ray et HD</a> (57)
</li>
	<li class="cat-item cat-item-4"><a href="https://nicolasforcet.com/category/cinema-serie-tv/" title="Les avis sur le cinéma et les séries TV">Cinéma et Séries TV</a> (146)
</li>
	<li class="cat-item cat-item-1234"><a href="https://nicolasforcet.com/category/electromenager/" title="Des tests de matériel électroménager : cafetières, robots cuisine, aspirateurs etc.">Electroménager</a> (6)
</li>
	<li class="cat-item cat-item-1392"><a href="https://nicolasforcet.com/category/finances-et-economie/">Finances et économie</a> (3)
</li>
	<li class="cat-item cat-item-5"><a href="https://nicolasforcet.com/category/fourre-tout/" title="Catégorie par défaut">Fourre tout</a> (495)
</li>
	<li class="cat-item cat-item-806"><a href="https://nicolasforcet.com/category/informatique/" title="Articles sur Linux, Windows et autres OS.">Informatique</a> (38)
</li>
	<li class="cat-item cat-item-505"><a href="https://nicolasforcet.com/category/internet-reseaux-sociaux/" title="Des news généralistes sur les réseaux sociaux et internet">Internet/Réseaux sociaux</a> (79)
</li>
	<li class="cat-item cat-item-1237"><a href="https://nicolasforcet.com/category/jeux-de-plateau/" title="Tests des derniers jeux de société/plateau à la mode.">Jeux de plateau</a> (3)
</li>
	<li class="cat-item cat-item-7"><a href="https://nicolasforcet.com/category/jeux-video-general/" title="Les tests et informations sur les jeux vidéos et consoles">Jeux Vidéos</a> (154)
</li>
	<li class="cat-item cat-item-1340"><a href="https://nicolasforcet.com/category/linux-raspberry-pi/" title="Tutoriels et bidouilles avec le mini PC Raspberry Pi">Linux et Raspberry Pi</a> (10)
</li>
	<li class="cat-item cat-item-1230"><a href="https://nicolasforcet.com/category/liseuses-ebooks/" title="Les actus et tests sur les liseuses électroniques et les ebooks">Liseuses (eBooks)</a> (9)
</li>
	<li class="cat-item cat-item-466"><a href="https://nicolasforcet.com/category/logiciels/" title="Tutoriels et bons plans sur les logiciels">Logiciels</a> (106)
</li>
	<li class="cat-item cat-item-8"><a href="https://nicolasforcet.com/category/musique/" title="Critiques d&#039;albums et news autour de la musique">Musique</a> (52)
</li>
	<li class="cat-item cat-item-1374"><a href="https://nicolasforcet.com/category/photo/">Photo</a> (3)
</li>
	<li class="cat-item cat-item-1325"><a href="https://nicolasforcet.com/category/rando-balades/" title="Topoguides de randonnées">Randonnées</a> (9)
</li>
	<li class="cat-item cat-item-387"><a href="https://nicolasforcet.com/category/mobilite-smartphones-tablettes/" title="Actualités et tests de smartphones, tablettes et autres appareils mobiles.">Smartphones, tablettes et mobilité</a> (118)
</li>
	<li class="cat-item cat-item-16"><a href="https://nicolasforcet.com/category/sport-extreme/" title="Des actualités dans le domaine du sport, notamment extrême">Sport &amp; Extreme</a> (70)
</li>
	<li class="cat-item cat-item-547"><a href="https://nicolasforcet.com/category/wordpress/" title="Quelques tutoriels sur le CMS Wordpress, que j&#039;utilise sur ce blog personnel.">Wordpress</a> (5)
</li>
	<li class="cat-item cat-item-6"><a href="https://nicolasforcet.com/category//actus-hi-tech/">Actualites-High-Tech</a> (84)
</li>
		</ul>
			</section>            </div>
			        <div class="clear"></div>
    </div>
</aside></div><!--#left -->


</div></div><!-- #content-wrapper,#content -->

<div id="copyright-container">
    <div class="inner hybrid">
				Copyright &copy; 2020 <a href="https://nicolasforcet.com" rel="home">Nicolas FORCET</a>
					
    </div>

</div>

</div><!-- #wrapper -->

<script type='text/javascript' src='https://nicolasforcet.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://nicolasforcet.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script async="async" type='text/javascript' src='https://nicolasforcet.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.3'></script>
<div id="side-pane">
    <div id="side-pane-inner"></div>
</div>


<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-2852753-4"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-2852753-4');
</script>

</body>
</html>
